Back to overview
Degraded

Inquiry Nepal's Main Website and MyLawyer Global are degraded

Aug 12, 2025 at 8:00am UTC
Affected services
Inquiry Nepal's Main Website
MyLawyer Global

Resolved
Aug 12, 2025 at 3:12pm UTC

MyLawyer Global recovered.

Updated
Aug 12, 2025 at 3:10pm UTC

MyLawyer Global is degraded.

Updated
Aug 12, 2025 at 1:28pm UTC

Inquiry Nepal's Main Website recovered.

Updated
Aug 12, 2025 at 1:26pm UTC

MyLawyer Global recovered.

Updated
Aug 12, 2025 at 1:25pm UTC

MyLawyer Global is degraded.

Updated
Aug 12, 2025 at 1:23pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
Aug 12, 2025 at 8:01am UTC

MyLawyer Global recovered.

Created
Aug 12, 2025 at 8:00am UTC

MyLawyer Global is degraded.