Back to overview
Degraded

Inquiry Nepal's Main Website is down

Aug 13 at 11:33am +0545
Affected services
Inquiry Nepal's Main Website

Resolved
Aug 13 at 11:53am +0545

Inquiry Nepal's Main Website recovered.

Created
Aug 13 at 11:33am +0545

Inquiry Nepal's Main Website is degraded.