Back to overview
Degraded
Inquiry Nepal's Main Website is down
Aug 14 at 09:05pm +0545
Affected services
Inquiry Nepal's Main Website
Resolved
Aug 14 at 09:30pm +0545
Inquiry Nepal's Main Website recovered.
Affected services
Created
Aug 14 at 09:05pm +0545
Inquiry Nepal's Main Website is degraded.
Affected services