Back to overview
Degraded

Inquiry Nepal's Main Website is degraded

Aug 17, 2025 at 8:44am UTC
Affected services
Inquiry Nepal's Main Website

Resolved
Aug 17, 2025 at 10:24pm UTC

Inquiry Nepal's Main Website recovered.

Updated
Aug 17, 2025 at 10:20pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
Aug 17, 2025 at 8:48am UTC

Inquiry Nepal's Main Website recovered.

Created
Aug 17, 2025 at 8:44am UTC

Inquiry Nepal's Main Website is degraded.