Back to overview
Degraded

Inquiry Nepal's Main Website is degraded

Aug 19, 2025 at 2:31am UTC
Affected services
Inquiry Nepal's Main Website

Resolved
Aug 19, 2025 at 4:38pm UTC

Inquiry Nepal's Main Website recovered.

Updated
Aug 19, 2025 at 4:32pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
Aug 19, 2025 at 2:38am UTC

Inquiry Nepal's Main Website recovered.

Created
Aug 19, 2025 at 2:31am UTC

Inquiry Nepal's Main Website is degraded.