Back to overview
Degraded

MyLawyer Global is down

Mar 9, 2026 at 8:51pm UTC
Affected services
MyLawyer Global

Resolved
Mar 9, 2026 at 9:04pm UTC

MyLawyer Global recovered.

Created
Mar 9, 2026 at 8:51pm UTC

MyLawyer Global is degraded.