Back to overview
Degraded

Inquiry Nepal's Main Website is down

Apr 22, 2026 at 5:18am UTC
Affected services
Inquiry Nepal's Main Website

Resolved
Apr 22, 2026 at 5:29am UTC

Inquiry Nepal's Main Website recovered.

Updated
Apr 22, 2026 at 5:23am UTC

Inquiry Nepal's Main Website is degraded.

Updated
Apr 22, 2026 at 5:22am UTC

Inquiry Nepal's Main Website recovered.

Created
Apr 22, 2026 at 5:18am UTC

Inquiry Nepal's Main Website is degraded.