Back to overview
Degraded

Inquiry Nepal's Main Website is down

Apr 29, 2026 at 5:33am UTC
Affected services
Inquiry Nepal's Main Website

Resolved
Apr 29, 2026 at 6:20am UTC

Inquiry Nepal's Main Website recovered.

Updated
Apr 29, 2026 at 6:15am UTC

Inquiry Nepal's Main Website is degraded.

Updated
Apr 29, 2026 at 5:38am UTC

Inquiry Nepal's Main Website recovered.

Created
Apr 29, 2026 at 5:33am UTC

Inquiry Nepal's Main Website is degraded.