Back to overview
Degraded

Inquiry Nepal's Main Website is down

May 4, 2026 at 6:09am UTC
Affected services
Inquiry Nepal's Main Website

Resolved
May 4, 2026 at 12:38pm UTC

Inquiry Nepal's Main Website recovered.

Updated
May 4, 2026 at 12:33pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 4, 2026 at 6:14am UTC

Inquiry Nepal's Main Website recovered.

Created
May 4, 2026 at 6:09am UTC

Inquiry Nepal's Main Website is degraded.