Back to overview
Degraded

Inquiry Nepal's Main Website and MyLawyer Global are down

May 6, 2026 at 6:54am UTC
Affected services
Inquiry Nepal's Main Website
MyLawyer Global

Resolved
May 6, 2026 at 6:13pm UTC

Inquiry Nepal's Main Website recovered.

Updated
May 6, 2026 at 6:07pm UTC

MyLawyer Global recovered.

Updated
May 6, 2026 at 6:05pm UTC

MyLawyer Global is degraded.

Updated
May 6, 2026 at 6:02pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 6, 2026 at 12:11pm UTC

Inquiry Nepal's Main Website recovered.

Updated
May 6, 2026 at 12:06pm UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 6, 2026 at 8:29am UTC

Inquiry Nepal's Main Website recovered.

Updated
May 6, 2026 at 8:24am UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 6, 2026 at 8:23am UTC

Inquiry Nepal's Main Website recovered.

Updated
May 6, 2026 at 8:18am UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 6, 2026 at 7:05am UTC

Inquiry Nepal's Main Website recovered.

Updated
May 6, 2026 at 7:00am UTC

Inquiry Nepal's Main Website is degraded.

Updated
May 6, 2026 at 6:59am UTC

Inquiry Nepal's Main Website recovered.

Created
May 6, 2026 at 6:54am UTC

Inquiry Nepal's Main Website is degraded.